Authentication with old password no longer supported, use 4.1 style passwords.

Apr 23, 2015 at 8:01 PM
I am using version 2.0.8,
I get this error when I try to connect
"Authentication with old password no longer supported, use 4.1 style passwords."

I am not sure where to even start? the MySQL install is 5.0.95.

Any ideas how to fix this?
Thanks
Coordinator
Apr 30, 2015 at 12:35 AM
what version of mysql server are you using?
Apr 30, 2015 at 8:32 AM
Edited Apr 30, 2015 at 8:35 AM
Hi,
I am not an MySQL expert, the database is hosted by Fasthosts
I think its version 5.0.95, is that not the version?

I am using phpAdmin
Version information: 4.0.10.9
And this is the info for the Database:
Server type: MySQL
Server version: 5.0.95-log - Source distribution
Protocol version: 10

Thanks
Coordinator
Apr 30, 2015 at 10:03 AM
Coordinator
Apr 30, 2015 at 10:04 AM
May 1, 2015 at 9:25 PM
I can't change the database ini file for the old_passwords=1, method.

this method makes little sense? not simplest.
simplest way is to Downgrade your mysql .netconnector to 5.0's version....
and add Reference of MySql.Data dll 2.0 from its folder in program files....

I am not sure why I am getting this error? is it a problem with MySqlBackup.NET?
Coordinator
May 2, 2015 at 12:13 AM
Don't worry, I have been using MySqlBackup.NET in my own both personal and commercial projects.
MySqlBackup.NET is working good.

Only there are some rare circumstances which might not been covered yet.
For example in this case.

Try to use the source code directly, don't use the pre-compiled DLL.

If you having trouble with 2.0.8, you can use the source code of 2.0.6
https://mysqlbackupnet.codeplex.com/SourceControl/changeset/23eab80e076c