Outdated MySQL package dependence

Nov 18, 2015 at 9:14 AM
When I'm installing your library from NuGet it also downloads MySQL as dependence. But your library is not working with current MySQL version (6.9.8) and requires version 6.9.7.

System.IO.FileLoadException: Не удалось загрузить файл или сборку "MySql.Data, Version=6.9.7.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d" либо одну из их зависимостей. Найденное определение манифеста сборки не соответствует ссылке на сборку. (Исключение из HRESULT: 0x80131040)
Имя файла: 'MySql.Data, Version=6.9.7.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d'
в QSUpdater.DB.DBUpdateProcess.ExecuteBackup()
в QSUpdater.DB.DBUpdateProcess.OnButtonOkClicked(Object sender, EventArgs e)

My exception translation: Unable to load file or assembly "MySql.Data, Version=6.9.7.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d". Found assembly manifest mismatch assembly reference. Etc...

I think you should maybe fix MySQL dependence to newer version or fix version checking. Something like this.

Thank you.
Coordinator
Jan 6, 2016 at 11:57 PM
Message read.
Will update at a later time.
thanks for the information.
Coordinator
Jan 9, 2016 at 8:21 AM
Hello, I have just updated the package.
You may try to add the nuget package again.